NFSv4 and rpcsec_gss for linux

The 2.6 Linux kernels now include support for version 4 of NFS. In addition to built-in locking and ACL support, and features designed to improve performance over the Internet, NFSv4 also mandates the implementation of strong cryptographic security. This security is provided by rpcsec_gss, a standard, widely implemented protocol that operates at the rpc level, and hence can also provide security for NFS versions 2 and 3.

...

Download PDF.