VMware Workstation 8.0.0 vs Linux Kernel 3.1.0

VMware Workstation 8.0.0 won't work on Linux Kernel 3.1.0 out of the box. But, some clever guy coded a very neat script that you can use to patch the workstation in a few easy steps:

$ cd /tmp
$ wget http://88.191.137.189/vmware3.1rc.sh
$ chmod +x vmware3.1rc.sh
$ su
# ./vmware3.1rc.sh

That should patch the modules source, recompile it and start the vmware services. I've also attached the courtesy copy of the script to this article, in case the remote location becomes unavailable.

Have fun!

AttachmentSize
vmware3.1rc.sh.txt1.11 KB

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

Patched vmware tools (for Fusion and Linux Kernel 3.1.0)

Thanks for the script, I used it as a starting point, then I refined it since there were other things broken. I am running Fusion 3, and the version of VMware Tools is 8.4.7.

Patch is here:

http://people.rpath.com/~misa/patches/vmware-fusion-linux3.tar.gz

Hope it helps.